Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
update check failed in 3.2.2

Basic scenario is this:

I have two sites with the same hosting company (although on different servers I think).

Site 1: is still using GS 3.2.1 and health check works as expected (i.e. shows that new version 3.2.2 is available).

Site 2: I have already updated to 3.2.2. Health Check shows as 3.2.2 but says 'Upgrade Check Failed' (all other sections below are green/OK).

I tried it with debug mode on and nothing showed up in the console. I also tweaked the healthcheck code to display $verstatus in the 'upgrade' message and it appears to be blank.

Any suggestions as to what might be causing this?

flush cache on settings page and try again, maybe it was unavailable when it was cached
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Hi Shawn,

Cleared Browser Cache and Flushed Cache within GS (settings page).

Still same message, nothing in errorlog nor on host's cpanel error log.

I'll keep digging - maybe try re-ftp'ing the 3.2.2 files up in case something got corrupted/skipped.

There were some changes to the curl api stuff, but I would think you would get fatal errors if we broek something, plus it works fine for me.

you can turn debugging on for the api in the configuration file.

debugapi = true;
nocache = true;

To the configuration.php and it will debug the api stuff into the console.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
ta, will try that and let you know how it goes.

the new template_functions file was setting the default API timeout to 500ms. Looking at 3.2.1 this used to default to 2 secs. I changed default timeout to 2 secs in my 3.2.2. version to test it and the health check worked OK.

I can provide the debug output if required in case this is CURL version related.

I forgot to modify configuration.php with the global api_timeout. So that is just the fallback.
This used to be important because we were calling the API constantly now not so much, althought I still would not want an off site API call to exceed 500ms, it might have been the issues the site was experiencing lately.

I might add some stats to see why our API is taking so long to respond.
API calls should be fast fast, like 60ms plus curl overhead.

Thanks for the find

To override this you can add
$api_timeout = 500; // request timeout in ms

to configuration.php
or gsconfig or anywhere else global.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix

Users browsing this thread: 1 Guest(s)