Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BETA RELEASE v3.3.0 release candidate
#1
http://get-simple.info/download
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#2
I will start compiling any doc changes for this. ( tagged documentation in github )

Extend is already updated to support this.
The hook and filter wiki documentation has also been documented.

Translation strings diffs not yet compiled.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
Really excited about this release. The new version of CKEditor, the new css in the menu. It's going to be a good one.

Checking it out tonight.
Reply
#4
Its not new new cke, its just 3.6 patch
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#5
Quote:NEW #605 Dynamic css classes in menus feature documentation
What does the feature documentation mean? Is that part of the wiki, or documentation in the cms-admin itself?

Is it CKeditor 3.6.6 or 3.6.6.1? http://ckeditor.com/release/CKEditor-3.6.6.1
Reply
#6
Those are github tags, ill probably clean them up, they get copy pasted with the titles. All documentation is wiki, there is no other documentation.

version:'3.6.6',revision:'7689'
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#7
(2014-01-09, 05:16:45)shawn_a Wrote: Its not new new cke, its just 3.6 patch
Well I am still excited about the new CKE when it comes, lol.
Reply
#8
And why not CKEditor Version 4.3.1?
Reply
#9
Try to stay on topic please.

Looks like lang diffs are very minimal ( waits for someone to nitpick the case )
and I didnt bump the lang header version, ugh, oh well

https://github.com/GetSimpleCMS/GS_LANGS...0e9b914e63
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#10
Hi Shawn,

I've just tidied up the language file (consistent tabs, spacing, fixed spelling of 'dimention' to 'dimension') if you would like to use it in 3.3.0 -
.php   en_US.php (Size: 19.73 KB / Downloads: 3)
Reply
#11
Its already tidied in 3.4, left alone now for easier diffing for translators, and so in don't have to merge the damn thing.

dimention ? good catch
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#12
(2014-01-10, 03:11:05)shawn_a Wrote: Its already tidied in 3.4, left alone now for easier diffing for translators, and so in don't have to merge the damn thing.

dimention ? good catch

Cool. 3.3 looking very good! Smile
Reply
#13
looks fine, only issue i found is http://i.imgur.com/mfzfh7B.png but i suppose that's due to a bug in the shortcodes plugin. Even if i don't remember noticing it before.

edit - more tests: ok, additional problem with shortcodes plugin: http://i.imgur.com/c4ssm9i.png
using beta 3 everything was fine. I didn't test b4
Reply
#14
Everything is working fine, but one error i see on admin login page >>>

Warning: Cannot modify header information - headers already sent by (output started at /.../sub/test/admin/index.php:17) in /.../sub/test/admin/template/header.php on line 19
Reply
#15
Thanks marrco, I think there was a css change to some stuff like pre elements I think , I will double check.
Are you sure this is new to 3.3.0 and not 3.2.3?
suspect, https://github.com/GetSimpleCMS/GetSimpleCMS/issues/625

I will try to reproduce evan, that makes sense though, I added some buffer flushing for people without output buffering on, to prevent login failures https://github.com/GetSimpleCMS/GetSimpleCMS/issues/647
Either this is causing an issue or you have an actual error somewhere breaking headers still.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#16
I'm getting the same "Cannot modify header information" on my remote hosting (PHP 5.3) but not on localhost (Uniform Server, PHP5.4) at the admin login page. Clean install, no extensions.
Reply
#17
I see the shortcode plugin issue way back on 3.2

I do not get any errors on login page.

evan, Plugins or clean install ?

I tried on several sites. hmm

Is this the only error you get ? Any notices ? after login ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#18
@shawn_a, you're right, i reloaded b3 and the issue was already present with that version. But maybe i spotted a minor estetic issue. Plugins now are sorted per plugin name, while in b3 were sorted per status, with disabled plugins at the top and enabled grouped at the bottom in admin/plugins.php.
Reply
#19
clean install, no plugins... i've deleted all dirs & upload again & i see only >>This page is temporarily unavailable...
Reply
#20
What is b3?

plugins were never sorted by status.
https://github.com/GetSimpleCMS/GetSimpleCMS/issues/710

You guys really should actually read the release notes.
Smile
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#21
(2014-01-11, 04:32:16)evan70 Wrote: clean install, no plugins... i've deleted all dirs & upload again & i see only >>This page is temporarily unavailable...

You must visit YOURSITE/admin so that the site is updated.
Reply
#22
(2014-01-11, 05:24:00)Carlos Wrote:
(2014-01-11, 04:32:16)evan70 Wrote: clean install, no plugins... i've deleted all dirs & upload again & i see only >>This page is temporarily unavailable...

You must visit YOURSITE/admin so that the site is updated.

srrry, I missed it Smile i'm on the road again ThX

now i see this > http://share.pho.to/4XfXz
Reply
#23
Yeah thats a known issue ( not new either ), for some reason that partiicular htaccess file is missing or uncheckable and that is how that plugin gets the install date. Not sure why you are missing it.

Maybe visit health check and try again.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#24
(2014-01-11, 14:27:29)shawn_a Wrote: ...
Maybe visit health check and try again.

After health check see this > http://share.pho.to/4Xoh1/o3/original
Reply
#25
Thanks for the reports, I am not sure what to do about those, anonymous data is being removed next version anyway.

And your errors are weird.

That is the file count scan on uploads, mine works fine even with empty directories, i am guessing its something unique to your install or a permissions issue.

If you figure it out or anyone can reproduce ill fix it.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels