Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED 500 Internal server error on re-install
I've been running GS for some time, and everything was fine.

I then fiddled around with the Grill theme, which installed way too much stuff that I didn't want to have. I probably deleted something that I shouldn't have and messed up my whole GS installation.

I therefore tried to re-install GS today, for several times (before that, I completely wiped all files from my webspace). I've downloaded the latest version from here, but everytime I try to access the admin folder to perform an install, I get a 500 internal server error.

I've checked the Apache access log and all it returns is
xx.x.xx.xx - - [04/Dec/2014:08:53:30 +0100] "GET /admin/install.php HTTP/1.1" 500 618 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36"

I've already checked the admin and data folders have correct permissions and CHMODed them recursively as has been suggested. There is no .htaccess file before installation, at least not in the root folder, so I assume it cannot be due to this.

Any ideas what else I could check? I am a bit at a loss what to do. Everything was working fine until yesterday, and I have no idea what is happening.
(2014-12-04, 18:24:27)sontom Wrote: I've checked the Apache access log

Any ideas what else I could check?

Check Apache's error log.
Something in your htaccess is probably incompatible with your host
Try commenting out the options stuff
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Okay, after fiddling around a bit more I contacted the support and they found some issues. Aparently permissions for the public_html folder were changed, and I am not sure if I did it accidently (which would be odd - I never make changes to any of the preconfigured files on my webspace) or those changes were introduced by one of the themes I tested.

Anyway, I can run GS now, however, I have to disable the htaccess file altogether (not sure why it's not working; but I have to comment everything out before I can access my page).

@moped: I have no direct access to Apache's error log.

@shawn_a: At some point I deleted all files that were in my webspace, except for a simple html file that had just one line of text in it, and a php file returning phpinfo() data. I still received a 500 server error, so I'd say that definitely had nothing to do with any htaccess file.
500 error is either 2 things.

1. bad directive in htaccess, or prohibited by host ( usually options -index or followsymblinks )
2. syntax error in a php file, easily discernable

reason will almost always be in your hosts error log
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix

Users browsing this thread: 1 Guest(s)