Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't iFrame a site built with GS v3.3.5
Has there been a deliberate change in 3.3.5, or something else?

Previously I've never had a problem placing any site built with GS, up to v3.3.4, into an iframe. With the default instal of v3.3.5 if I place the site in an iframe (on some other site) it does not appear. The source code of the iframe actualy has no content in my browser.

Is this something to do with .htaccess or what?
EDIT: my bad looks like this applies to front end and backend, and should only be blocking back end and logins
So the docs are wrong.

you should read release notes when updating stuff

PHP Code:
# GS prevents backend pages from being loaded in a frame
# by sending an x-frame header by default to prevent clickjacking attempts
# setting GSNOFRAME to false will disable this
# define('GSNOFRAME',false); 

It looks like this is preventing front end also, i don't know if I changed my mind and meant to change that, or i put the code outside the brackets on accident.
I think this is a bug.

This should probably only apply to backend.

Either way
will fix it
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Thanks Shaun
define('GSNOFRAME',false); fixed it for me. I also tried other options from your Github post link, but "true or 1 (default) backend only" killed the front end too, so I'll just do without the function for now.
Thanks again for fast solution.
Those other options are not valid, just suggestions I made.
Yeah false turns it off, your fine.

You should copy any new settings in gsconfig into yours when you upgrade, so you have them.
You can find them in the temp config file, or at least check the temp for new configs.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix

Users browsing this thread: 1 Guest(s)