Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PROBLEM Upgrade to CKEDITOR 4.5.7 with GS version 3.3.9
This is an information for users of advanced configuration of the editor, like it is described in the WIKI (using custom config file and "define('GSEDITOROPTIONS')" in the gsconfig.php

If configured to use a different skin for the editor, you have to do change the configuration.

the skins have to be updated, the "old" skins are not compatible
you will find the actual skins at

download the one you want, extract the zip

delete the custom skin files at the server in the folder /admin/template/js/ckeditor/skins
upload the skin-folder to /admin/template/js/ckeditor/skins

now modify the following in gsconfig.php, you have to delete the last part, ",skin:'name of the skin' must be deleted

define('GSEDITOROPTIONS', "entities : false,forceSimpleAmpersand:true,customConfig : '../../../../theme/gs.js',skin:'kama'");

define('GSEDITOROPTIONS', "entities : false,forceSimpleAmpersand:true,customConfig : '../../../../theme/gs.js'");

c) now you have to add a new configuration in the customConfig-file (if you have, if you have not read the WIKI):

CKEDITOR.editorConfig = function( config )

    config.toolbarCanCollapse = true,
    config.enterMode = CKEDITOR.ENTER_P,
    config.shiftEnterMode = CKEDITOR.ENTER_BR,
    config.colorButton_enableMore = true,
    config.bodyId = 'content',
    config.entities = false,
    config.forceSimpleAmpersand = false,
    config.fontSize_defaultLabel = '12px',
    config.font_defaultLabel = 'Arial',
    config.font_names = 'Arial/Arial, Helvetica, sans-serif;' +  'Times New Roman/Times New Roman, Times, serif;' +  'Verdana;'
    config.emailProtection = 'encode',
    config.contentsLangDirection = 'ltr',
    config.language = 'de',
    config.contentsLanguage = 'de',
    config.toolbarLocation = 'top',
    config.browserContextMenuOnCtrl = false,
    config.extraPlugins = 'fileicon,video,youtube,templates',
    config.syntaxhighlightLangDefault = 'php', = 'minimalist',
    config.templates_replaceContent = false,

the above code is an example, I added here the line: = 'minimalist', to use the skin "minimalist" which I downloaded before

Last step:
clear your browsers cache
log into GetSimple admin
go to "Settings"
clear the GS cache
create a new page, you should see the new skin

Das deutschsprachige GetSimple-(Unter-)Forum:
If you don't get your editor at all, you also have to check whether any of the additional editor-plugins which you might have added and defined in your configuration, should be updated or deleted.

I had to delete the "video"-plugin for example. After doing so I got my editor back!

Das deutschsprachige GetSimple-(Unter-)Forum:
I forgot:

I also had to delete one line in my custom-config-file:


this seems to be incompatible as well

Das deutschsprachige GetSimple-(Unter-)Forum:
It appears that ckeditor no longer exposes the toolbar_Full to config() for some reason. It might be built at runtime now.
News to me, thanks.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
How might I get CKE's "Templates" plugin working again with GS versions 3.3.9 & 3.3.10?
(It worked ok with the 3.3.8 + CKE patch plugin)

Is a custom config file with "config.extraPlugins = 'fileicon,video,youtube,templates'," now required for that?
hmm, i am unfamiliar with that plugin , nothing regarding loading plugins should have changed, unless they are incompatible of course.

Got links ?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Well, this is a bit embarrassing but I decided to triple check my failed trouble shooting attempts before responding and this time one of them yielded results.  (I'd overlooked the ampersand in my earlier attempts. OOPS!)

In version 3.3.9 Some of the characters in the Templates'  js  (ckeditor\plugins\templates\templates\default.js) were changed to (forgive me for not knowing the correct terms) escape codes.  This altered default.js is included with 3.3.10 as well.
That is to say < was changed to \x3c and so on.  
Now, that I've restored the < > = and &amp;  the Templates' default.js is loading up just fine (I have not tried any custom templates yet.)
I have a new problem:
GS is uptodate
GS-Systemcheck: everything is ok

but CKEditor:
writing new pages is possible, the editor is loaded
editing existing pages is not possible, no editor at all ... unfortunately this is a client webpage and their website is not functional anymore after moving to new server with PHP 7 (MLD Newsletter plugin broken!) and now this..

I can't find an explanation why the editor is not loaded

Das deutschsprachige GetSimple-(Unter-)Forum:
hmmm, I did not see any issues reported similar to this, there are alot of plugins that are broken in php7 however.

I am trying to think of one that is loading when editing a page.

definitely a js error it sounds like

Any ckeditor plugins added?
was the config.js modified or any overrides in gsconfig ?

There was one error that occurs when using a toolbar, some syntax changed in cke and it has to be updated.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
thank you for the hint - some extraplugins which were set in the custom config file were missing

stupid mistake ;=)

Cheers, Connie

Das deutschsprachige GetSimple-(Unter-)Forum:
Thanks !!

Users browsing this thread: 1 Guest(s)