Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PROBLEM No automathical thumbnails creation
Wanting to use a gallery plugin that worked not for me I have noticed that I miss automatically created thumbnails in some my GetSimple installations. It applies only to localhost installations in fact, I have also a server installation where thumbnails are created correctly. I suspect that it is a matter of permissions or an owner but I can't find the solution. While checking directories permissions in the host server installation via FTP using the Midnight Commander file manager I noticed that all directories have the name of my user account in the system as an owner and a group. But some directories in my localhost installations have my user name as an owner and the "www-data" as a group and some of them (e.g. data/uploads/images, the directory created by me in the GetSimple administration) have even "www-data" as both an owner and a group (that applies also to all images uploaded through the GetSimple administration in the data/uploads/images directory). This difference in an owner of directories between the host server and localhost installations might be the cause why no thumbnails of uploaded images are created authomatically in my localhost installations but I am not able to find a solution. I changed the owner and the group of all directories and files in one my localhost installation (using chown), then I uploaded an image using GetSimple administration (Files tab) and the image has again www-data as an owner and a group. So I don't know, maybe Apache or PHP does this. But maybe this is normal on localhost and it is not the real cause why I have no thumbnails, however I have no other idea. I ask for help. Thank you.
P.S. Every time I installed the GetSimple on localhost the installation didn't finish because a problem of renaming temp.htaccess and temp.gsconfig.php appeared due to permission problems and I had to do it manually; I had no such problem during a host server installation. (However Website Health Check displays "chmod - OK".)
It is solved already. Missing GD PHP module was at fault, no permissions.

Users browsing this thread: 1 Guest(s)