Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PROBLEM Error 500
#1
I'm installing GetSimple CMS for the first time and I got passed the login page of the installation where it said it couldn't send out my password to my email then displayed my password along with the option to login, then I got this message:

"Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.
If you think this is a server error, please contact the webmaster.
Error 500
localhost
Apache/2.4.25 (Win32) OpenSSL/1.0.2j PHP/5.6.30 "

I tried to re-install my going back to "localhost/mysite/admin" but now all I get is the same error message.

What am I doing wrong?

Any help will be greatly appreciated.
Reply
#2
check your host error log, that is a fatal php error typically or a config error, perhaps somethig in our .htaccess is not happy,
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
oh and read the STICKIES

http://get-simple.info/forums/showthread.php?tid=6830
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#4
(2017-05-18, 10:22:17)IllusiaX Wrote: I'm installing GetSimple CMS for the first time and I got passed the login page of the installation where it said it couldn't send out my password to my email then displayed my password along with the option to login, then I got this message:

"Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.
If you think this is a server error, please contact the webmaster.
Error 500
localhost
Apache/2.4.25 (Win32) OpenSSL/1.0.2j PHP/5.6.30 "

Can you post the .htaccess-File that is online?

Alex
Reply
#5
(2017-05-18, 11:36:10)shawn_a Wrote: oh and read the STICKIES

http://get-simple.info/forums/showthread.php?tid=6830

Sorry, it was super late and I was fried and didn't even think.
Reply
#6
(2017-05-18, 23:55:26)Alexander_ Wrote:
(2017-05-18, 10:22:17)IllusiaX Wrote: I'm installing GetSimple CMS for the first time and I got passed the login page of the installation where it said it couldn't send out my password to my email then displayed my password along with the option to login, then I got this message:

"Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.
If you think this is a server error, please contact the webmaster.
Error 500
localhost
Apache/2.4.25 (Win32) OpenSSL/1.0.2j PHP/5.6.30 "

Can you post the .htaccess-File that is online?

Alex
I don't have anything online. I'm trying to install it on a local server.

I changed the 'Rewrite Base' to my subdirectory folder as instructed in the .htaccess-File.

According to my apache error logs: AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name

According to some research: server name used in Apache (httpd.conf) must be the same as the server name in apache (httpd-ssl.conf)

I've tried this and I still get the same error.
Reply
#7
(2017-05-19, 08:55:24)IllusiaX Wrote:
(2017-05-18, 23:55:26)Alexander_ Wrote: Can you post the .htaccess-File that is online?

Alex
I don't have anything online. I'm trying to install it on a local server.

I changed the 'Rewrite Base' to my subdirectory folder as instructed in the .htaccess-File.

According to my apache error logs: AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name

According to some research: server name used in Apache (httpd.conf) must be the same as the server name in apache (httpd-ssl.conf)

I've tried this and I still get the same error.

You DO have a .htaccess-File, even on local installations. I think the reason for the error is, that you tried to call your local site via SSL (https://localhost in spite of http://localhost) without having an SSL-ceritficate

Alex
Reply
#8
(2017-05-19, 21:13:24)Alexander_ Wrote:
(2017-05-19, 08:55:24)IllusiaX Wrote:
(2017-05-18, 23:55:26)Alexander_ Wrote: Can you post the .htaccess-File that is online?

Alex
I don't have anything online. I'm trying to install it on a local server.

I changed the 'Rewrite Base' to my subdirectory folder as instructed in the .htaccess-File.

According to my apache error logs: AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name

According to some research: server name used in Apache (httpd.conf) must be the same as the server name in apache (httpd-ssl.conf)

I've tried this and I still get the same error.

You DO have a .htaccess-File, even on local installations. I think the reason for the error is, that you tried to call your local site via SSL (https://localhost in spite of http://localhost) without having an SSL-ceritficate

Alex

This is my htaccess-File, I followed the instructions fro RewriteBase but I'm guessing there is more I need to do but havent. I've never installed one of these before, this is all new to me.


#
# GetSimple CMS htaccess ROOT file
# apache 2.4
#

# The following require certain allow overrides, if getting 500 error comment them out one by one
# can be resolved in apache httpd.conf to ensure security alternatives

# override charset
AddDefaultCharset UTF-8

# prevent directory listings
Options -Indexes

# Follow symbolink links, This is required for rewrites on some hosts
Options +FollowSymLinks

# Set the default handler.
DirectoryIndex index.php

# blocks direct access to the XML files - they hold all the data!
<Files ~ "\.xml$">
    <IfModule !mod_authz_core.c>
        Deny from all
    </IfModule>
    <IfModule mod_access_compat.c>
        Deny from all
    </IfModule>
    <IfModule mod_authz_core.c>
        <IfModule !mod_access_compat.c>
            Require all denied
        </IfModule>
    </IfModule>    
</Files>

<Files sitemap.xml>
    <IfModule !mod_authz_core.c>
        Allow from all
    </IfModule>
    <IfModule mod_access_compat.c>
        Allow from all
    </IfModule>
    <IfModule mod_authz_core.c>
        <IfModule !mod_access_compat.c>
            Require all granted
        </IfModule>
    </IfModule>    
</Files>

# handle rewrites for fancy urls
<IfModule mod_rewrite.c>
    RewriteEngine on

    # Usually RewriteBase is just '/', but
    # replace it with your subdirectory path
    RewriteBase C:\xampp\htdocs\princeandprincessevents\admin    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule /?([A-Za-z0-9_-]+)/?$ index.php?id=$1 [QSA,L]
</IfModule>

Thank you so much for your help.
Reply
#9
Try this:
RewriteBase /htdocs/princeandprincessevents/

Alex
Reply
#10
have you commented out the options one by one ? Some hosts do not allow those
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#11
Shouldn't it be
Code:
RewriteBase /princeandprincessevents/
?
Reply
#12
Thank you for the replies guys, but unfortunately none of them have worked, I still get the same error.
Reply
#13
Didnyou check apache error log?
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#14
(2017-05-23, 07:07:12)IllusiaX Wrote: Thank you for the replies guys, but unfortunately none of them have worked, I still get the same error.

RewriteBase C:\xampp\htdocs\princeandprincessevents\admin
is definitely wrong.

So try one of these

RewriteBase /
RewriteBase /htdocs/
RewriteBase /htdocs/princeandprincessevents/

Don't use the backslash \ but the slash / to separate the directories.
And make a new line before you write RewriteCond %{REQUEST_FILENAME} !-f

Alex
Reply
#15
(2017-05-23, 01:22:57)Carlos Wrote: Shouldn't it be
Code:
RewriteBase /princeandprincessevents/
?

I guess c:/xampp/ is apaches root. So /htdocs/princeandprincessevents/ is probably tho correct RewriteBase.

Alex
Reply
#16
I was assuming that Apache's root is c:/xampp/htdocs and GS is installed in /princeandprincessevents/
But who knows.

Anyway the .htaccess file should have been generated properly when installing GS - no need to edit the rewritebase if the installation was successful.
Reply
#17
(2017-05-25, 02:09:33)Carlos Wrote: I was assuming that Apache's root is c:/xampp/htdocs and GS is installed in /princeandprincessevents/
But who knows.

Anyway the .htaccess file should have been generated properly when installing GS - no need to edit the rewritebase if the installation was successful.

The installation wasn't successful. I've been trying to install it and I get the error.
Reply
#18
(2017-05-24, 02:22:51)Alexander_ Wrote:
(2017-05-23, 07:07:12)IllusiaX Wrote: Thank you for the replies guys, but unfortunately none of them have worked, I still get the same error.

RewriteBase C:\xampp\htdocs\princeandprincessevents\admin
is definitely wrong.

So try one of these

RewriteBase /
RewriteBase /htdocs/
RewriteBase /htdocs/princeandprincessevents/

Don't use the backslash \ but the slash / to separate the directories.
And make a new line before you write RewriteCond %{REQUEST_FILENAME} !-f

Alex

I'm afraid I'm still getting the same error.
Reply
#19
My apache error logs say this: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name

But I'm not sure how to fix it.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels