Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PROBLEM Installing on debian 9 does not work
#1
Hi,

I wanted to evaluate GetSimpleCMS and installed the current version (3.3.13) on a debian 9 (64 bit) running as a virtual host on an ESXi 5.5 server.

I installed SimpleXML (apt-get install php-xml andapt-get install php7.0-xml), enabled mod_rewrite (a2enmode rewrite) and also installed the other modules (zip, gd, curl).

I copied the extracted archive to /var/www/html/<somesubdirname> and tried also copying it directly to /var/www/html but with the same result...

The problem is that if I open the browser at .../admin, I do not see the installation but have a very bad formatted login with this text, so there is not the "LOGIN" but ALL the code including the gt and le symbols...

Code:
<?php i18n('LOGIN'); ?>

If i try to open the normal website I also get some unparsed code:
Code:
title; $date = $data_index->pubDate; $metak = $data_index->meta; $metad = $data_index->metad; $url = $data_index->url; $content = $data_index->content; $parent = $data_index->parent; $template_file = $data_index->template; $private = $data_index->private; // after fields from dataindex, can modify globals here or do whatever by checking them exec_action('index-post-dataindex'); # if page is private, check user if ($private == 'Y') { if (isset($USR) && $USR == get_cookie('GS_ADMIN_USERNAME')) { //ok, allow the person to see it then } else { redirect('404'); } } # if page does not exist, throw 404 error if ($url == '404') { header($_SERVER["SERVER_PROTOCOL"]." 404 Not Found"); } # check for correctly formed url if (getDef('GSCANONICAL',true)) { if ($_SERVER['REQUEST_URI'] != find_url($url, $parent, 'relative')) { redirect(find_url($url, $parent)); } } # include the functions.php page if it exists within the theme if ( file_exists(GSTHEMESPATH .$TEMPLATE."/functions.php") ) { include(GSTHEMESPATH .$TEMPLATE."/functions.php"); } # call pretemplate Hook exec_action('index-pretemplate'); # include the template and template file set within theme.php and each page if ( (!file_exists(GSTHEMESPATH .$TEMPLATE."/".$template_file)) || ($template_file == '') ) { $template_file = "template.php"; } include(GSTHEMESPATH .$TEMPLATE."/".$template_file); # call posttemplate Hook exec_action('index-posttemplate'); ?>

Debian 9 uses php7.0, so I expect that the problem is this new php, even if the requirements for GSCMS is 5.2+...

I was able to install GSCMS a few weeks ago on an old debian 8 installation (with php 5.6.30) but as the new base will be a debian 9, I need it up and running there.

Any hints on how to install it on this new distro?

If it can't be installed on this system, then I would need to look for another cms ,-(

Best regards,
 Andreas.
Reply
#2
Your php is not working
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
(2017-06-20, 08:09:25)shawn_a Wrote: Your php is not working

Thanks, I just realized that on my own... The libapache2-mod-php7.0 is NOT enabled / installed on debian9 by default Angry

I installed it with "apt-get install libapache2-mod-php7.0" and voila, it works. (I have to resolve some folder permission and the installation of the zip-module is not recognized, but these are minor issues...)

Thanks again!
 Andreas.
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels