Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Link to onsite dir & index.htm page
#1
I need to link to an onsite dir & index.htm page
(I have numerous media directories and I have my own custom php page that creates thumbnails for a gallery - it automatically creates a index.htm in the subdirectory)

When I create a link to the index.htm file I get a "Forbidden" error. How can I allow index.htm to run in that sub directory?dir &
Thanks,
jwzumwalt
(\__/)
(='.'=)
(")_(")
Reply
#2
Where are they located? theme?

Add an allow htaccess file ( you can find them in admin/tmp)
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#3
(2017-10-06, 02:20:33)shawn_a Wrote: Where are they located? theme?

Add an allow htaccess file ( you can find them in admin/tmp)

Still not getting it to work. I ether get a forbidden, or server internal error.
The directory I am trying to give user access is off the "uploads" directory.

I am upgrading a mega-site so I might have to come back to this problem.
Thanks,
jwzumwalt
(\__/)
(='.'=)
(")_(")
Reply
#4
(2017-10-06, 10:44:55)jwzumwalt Wrote:
(2017-10-06, 02:20:33)shawn_a Wrote: Where are they located? theme?

Add an allow htaccess file ( you can find them in admin/tmp)

Still not getting it to work. I ether get a forbidden, or server internal error.
The directory I am trying to give user access is off the "uploads" directory.

I am upgrading a mega-site so I might have to come back to this problem.

Hi jw,

The uploads directory has a default .htaccess (which you can also view on Github). 
In fact if you look at line 30, that might be the problem. You mentioned index.htm, and the <FilesMatch> has a DENY rule for files ending in .htm. So you'll either have to adjust the regex (e.g. remove all the [mM] blocks), or adjust your index files to have the .html extension instead (which is, remarkably, not affected by the directive).

Depending on your Apache version (2.2- vs. 2.4+), and whether you have mod_access_compat enabled, you might need to do couple of tweaks. For more details, you can read this issue about htaccess config in GetSimpleCMS.
Reply
#5
I guess we can add html to that, odd that it was missed.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#6
Quote:Hi jw,

The uploads directory has a default .htaccess (which you can also view on Github). 
In fact if you look at line 30, that might be the problem. You mentioned index.htm, and the <FilesMatch> has a DENY rule for files ending in .htm. So you'll either have to adjust the regex (e.g. remove all the [mM] blocks), or adjust your index files to have the .html extension instead (which is, remarkably, not affected by the directive).

Depending on your Apache version (2.2- vs. 2.4+), and whether you have mod_access_compat enabled, you might need to do couple of tweaks. For more details, you can read this issue about htaccess config in GetSimpleCMS.

Thanks Tyblitz, that was the problem...

I just commented out all the deny and the htm & php work.
I'll come back later and figure out how to make it a case by
case basis for the desired directory.
Thanks,
jwzumwalt
(\__/)
(='.'=)
(")_(")
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels