Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My Template
#1
Template with built-in components. Components can be configured in the admin panel.

Demo & Download:
http://get-simple.info/extend/theme/my-template/1260/


Attached Files Thumbnail(s)
           
Reply
#2
(2020-05-15, 03:37:17)denis Wrote: Template with built-in components. Components can be configured in the admin panel.

Demo & Download:
[/url][url=http://get-simple.info/extend/theme/my-template/1260/]http://get-simple.info/extend/theme/my-template/1260/

wow!
Reply
#3
Lovely template, just downloaded and installed, but should it contain demo components? Thanks
Reply
#4
(2020-05-15, 07:04:38)davetest Wrote: Lovely template, just downloaded and installed, but should it contain demo components? Thanks

If it comes to "My SMTP Contact" and "My Gallery" plugins, then no. These plugins are installed separately. They are available for download.
Reply
#5
If I make any changes in My Template Plugin config they do not save. I am using GS site in a sub directory, could that be a problem?
Reply
#6
(2020-05-15, 16:11:41)davetest Wrote: If I make any changes in My Template Plugin config they do not save. I am using GS site in a sub directory, could that be a problem?

Perhaps, because of this, the settings are not saved in the right place. Maybe file permissions may not be set.
But I installed the standard CMS without any configuration changes. There were no such problems.

Demo site on subdomain and subdirectory.
But I had to make changes to .htaccess in the root directory. But this applies only to my case, because I use free hosting. On my hosting, the subdomain can only be directed to the root directory.
RewriteEngine on
RewriteCond %{ENV:REDIRECT_VHOST} ^$
RewriteCond %{HTTP_HOST} ^(www\.)?(.+)\.p9021271\.beget\.tech$
RewriteRule ^(.*) %2/$1 [L,E=VHOST:1]
I don’t think it will help you.

The configuration is written as follows: '../plugins/my-template/cfg.php'
Edit: /plugins/my-template.php  & /theme/template.php -> 
Comment out the line: Error_Reporting(E_ALL & ~E_NOTICE);  It is almost at the beginning of the code. 
See if there are any errors.

There were no problems on the local server and in the root directory. And on subdomains on the local server everything also works.
Reply
#7
Hi Denis. I'm still playing with site in sub directory and just found another issue. In My_Template home page the navigation buttons in Component 7 (frontend) do not work. Move site to domain root and buttons now work. Hope that helps with development with a otherwise brilliant template.
Reply
#8
(2020-05-21, 04:01:11)davetest Wrote: Hi Denis. I'm still playing with site in sub directory and just found another issue. In My_Template home page the navigation buttons in Component 7 (frontend) do not work. Move site to domain root and buttons now work. Hope that helps with development with a otherwise brilliant template.

Thank you for the information, I will keep this in mind. So far, the theme only works correctly in the root directory. In the next version, I will try to fix it.
Reply
#9
Version 1.0.1:

- fixed a problem with the theme working in the main domain subdirectory (site.com/subdomain/GetSimple files).

Make sure everything is correct here: Settings => Website URL
Something like this: http://site.com/subdomain/
In site.com/subdomain/ must be GetSimple files
Reply
#10
(2020-05-22, 00:40:47)denis Wrote: Version 1.0.1:

- fixed a problem with the theme working in the main domain subdirectory (site.com/subdomain/GetSimple files).

Make sure everything is correct here: Settings => Website URL
Something like this: http://site.com/subdomain/
In site.com/subdomain/ must be GetSimple files

Hi Denis. Thanks again for your great work. I've installed this update (and your 2 other plugin updates today) and all work great in a sub directory, as well as in site root. I'll now be able to get on and work on my site (so I'll be back to donate for sure).

Meanwhile, although I love your version of the Graphberry Pluton theme, I'd really love my first component to be fullpage image based, a bit like Graphberry's Kasper template. Is that easilly possible within your current framework? ...a long shot I know, but thought it worth asking :-) ...and thanks again!
Reply
#11
(2020-05-22, 00:40:47)davetest Wrote: I'd really love my first component to be fullpage image based, a bit like Graphberry's Kasper template.

Hi.
Templates have a different version of Bootstrap.
Using a full-screen slider as in the Graphberry's Kasper template is possible, but reworking will take some time.
I will see if this is not too difficult for me, maybe later. Yes, the full-screen slider looks better.
Reply
#12
(2020-05-22, 19:10:43)denis Wrote:
(2020-05-22, 00:40:47)davetest Wrote: I'd really love my first component to be fullpage image based, a bit like Graphberry's Kasper template.

Hi.
Templates have a different version of Bootstrap.
Using a full-screen slider as in the Graphberry's Kasper template is possible, but reworking will take some time.
I will see if this is not too difficult for me, maybe later. Yes, the full-screen slider looks better.

Thnx Denis if you were able to give your template a fullscreen slider it really would be the 'icing on the cake'
Reply
#13
Version 1.0.2:
- on/off components & content in main page
- two slider options to choose from
Reply
#14
Feedback on v1.02:
1. Great addition of Full Page Slider.
2. Great addition of Select Components which appear.
...all working fine on my development site.

Feature Wishlist:
1. Choose order of components, maybe drag-n-drop Component sections in the Plugin?
2. Select which features appear in other (not index) pages?
3. Native GS popup to select slider images from GS Files section or Template's default folder?

Question:
Is it possible to move which position GS Content appears in the component order. How to manually? or could that be a feature in the Plugin (nice addition to my wish 1)?

Again thanks for great template.
Reply
#15
A further suggestion: Can contact form in Component 9 be displayed in a slightly different way? In desktop browser it displays over part of map, that's ok but not necessary best. But on mobile browser the contact form totally covers the map. I realize that this is the same in original Graphberry Pluton theme, but it would be nice to make it better.
Reply
#16
...and how about adding a Lightbox type script for the images in Component 3 and other areas where image thumbnails can link to larger images?
Reply
#17
I do not see the point in changing anything. Let it stay as it is.
This is a hobby. Maybe later, when I have a desire to change something in this template.
Reply
#18
(2020-05-24, 23:53:38)denis Wrote: I do not see the point in changing anything. Let it stay as it is.
Maybe later, when I have a desire to change something in this template.

Oops! Hope I've not offended by giving feedback, but you've asked for that on this forum before. Fully aapreciate your work and fully understand it being just a hobby, me too! I'm sure others also love your contributions to GS too. Well done again on what you have made of this template into. Best regards.
Reply
#19
(2020-05-25, 00:43:47)davetest Wrote:
(2020-05-24, 23:53:38)denis Wrote: I do not see the point in changing anything. Let it stay as it is.
This is a hobby. Maybe later, when I have a desire to change something in this template.

Oops! Hope I've not offended by giving feedback, but you've asked for that on this forum before. Fully aapreciate your work and fully understand it being just a hobby, me too! I'm sure others also love your contributions to GS too. Well done again on what you have made of this template into. Best regards.

I do not consider it necessary to enter order for components, I believe they are only necessary on the home page. Especially, in order to implement this, it is necessary to significantly change the existing code.
Displaying components on certain pages is not difficult, but I do not think it is necessary.
And Component 3 was originally conceived not as a gallery, but as blocks with the ability to navigate a link to another page.
I don 't see the need to change the layout of the contact form either.

So many people, so many tastes :-)

Thanks for testing the template. And for the wishes for its improvement. I will keep that in mind.

davetest Wrote:Is it possible to move which position GS Content appears in the component order. How to manually?

See in template.php file:
Components:
<?php if ($my_template_component1 == 'on') :?>
...
<?php endif;?>
Copy the contents of this block to another location in a template.
Also, by analogy for each component.

GS Content in main page:
<?php if ($my_template_index_page_content == 'on' && return_page_slug() == 'index') :?>
...
<?php endif;?>
Reply
#20
Version 1.0.3:
- The ability to upload images and their previews in the admin panel
- In the layout added "id" for components... 
If you are making a one page website: Custom Permalink Structure: %parent%#%slug% 
Anchors: #component1 - #component10; #page-content
Reply
#21
Thankyou for v1.0.3. Love the image upload feature, makes it so much easier.
I tried it as a onepager, but needed to add id="page-content" to template.php.
Thanks for your previous info tips too, I'll enjoy working further with this. Thanks again.
Reply
#22
(2020-06-03, 10:13:24)davetest Wrote: I tried it as a onepager, but needed to add id="page-content" to template.php.

Yes, I forgot to write this ID. Then made corrections.
But, yesterday I have updated the archive with the template. You can download it again, there should be this ID.
Minor adjustments have also been added.
Reply
#23
Thanks for updated v1.0.3 and well done with fixing the onepage anchor offset so well (and I prefer the new menu bar anyway).
Maybe this is slightly off-piste, but I've found a conflict when also installing your My_Gallery plugin with this template. Both work ok together except that with My_Gallery activated the GS Page Title appears where it should, but GS Page Content does not appear. DeActivate My_Gallery plugin and it works again.
I also tried your My_SMTP plugin too in this scenario, but that works no problem!
Reply
#24
(7 hours ago)davetest Wrote: Thanks for updated v1.0.3 and well done with fixing the onepage anchor offset so well (and I prefer the new menu bar anyway).
Maybe this is slightly off-piste, but I've found a conflict when also installing your My_Gallery plugin with this template. Both work ok together except that with My_Gallery activated the GS Page Title appears where it should, but GS Page Content does not appear. DeActivate My_Gallery plugin and it works again.
I also tried your My_SMTP plugin too in this scenario, but that works no problem!

Are you using the latest plugins and template?
Download them again, maybe I changed something, but I didn 't change their versions.

3 galleries are connected here using short-codes inside GS content: http://demo23.p9021271.beget.tech/index....my-gallery
Reply
#25
Bang-on denis! Downloaded new My_Gallery v1.0.3 and it worked again. I think I may have grabbed it last time just after your v1.0.3 announcement and got an early copy. Now dreaming of you developing more great GS stuff ...maybe one day, your Catalog/Cart from your MyEngine plugins? :-)
Thanks again
Reply




Users browsing this thread: 1 Guest(s)