Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I18N Gallery
(2015-04-24, 01:54:57)Oleg06 Wrote: Martin, Google are increasingly demanding to place scripts at the bottom of the template. May be it makes sense to correct all your plugins?
imho, google can go fly a kite. i put scripts (when i use them) where i want or need them in source. google's suggested location is only relevant to, and only speeds up rendering of, a visitor's first page view, after that, the stuff should be browser cached anyway.. and if you use cdn for the big stuff, likely to be cached even on that first hit. gzipping and proper caching is far more important than the location of a script in your output source code. it (scripts on the bottom) was a trend promoted by google originally to ensure that their google analytics scripts did not have any impact on page render times for all the sites that get sucked into giving google their visitor histories.
Reply
Placing scripts in the footers is called non-blocking asset loading, basically your page can start to load before assets are loaded, this is a suggestion for good practice, it is in no way required or necessary especially for small sites its likely to make no difference.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
Hello, i am looking for a solution to have the I18N Gallery thumbnails running in a carousel.
Unfortunately my coding-knowledge is not enough for this.
Maybe someone has a suggestion for me.

Thank you in advance.
Reply
I would love to use this extension - however I am getting a page not found error when attempting to upload images for the gallery - thus the save fails - in the documentation I found: "if the file plugins/i18n_gallery/gallery.xml was copied to data/pages" this file does not exist in the i18n-gallery.zip
Reply
(2015-07-04, 02:01:08)bluzer Wrote: I would love to use this extension - however I am getting a page not found error when attempting to upload images for the gallery - thus the save fails - in the documentation I found: "if the file plugins/i18n_gallery/gallery.xml was copied to data/pages" this file does not exist in the i18n-gallery.zip

Have you ckecked the info regarding Problem Solving over here:
http://get-simple.info/forums/showthread...5#pid12235

Quote:If you encounter problems when creating and saving or deleting galleries in the back end,
  • check if the file plugins/i18n_gallery/loadtab.php was copied to admin - correct it manually if necessary
  • check if a directory data/i18n_gallery exists and is read- and writeable - correct it manually if necessary
  • check if a directory backups/i18n_gallery exists and is read- and writeable - correct it manually if necessary
Reply
Hello,

I have build a gallery and can start slideshow automatically if I mark the correspondent adjustment in "options". But I don't want to start slideshow automatically, because text of the page where the gallery has to be shown should have been read first.

So I am looking for a solution that I can place a link on the page above the gallery with text "start slideshow" and if user clicks on this link the slideshow should start.

I am using prettyPhoto and can't get this work... If I mark "autostart" user can / must interrupt slideshow and can start it again clicking on one of the thumbnails - but that is not much elegant.

Is there a possibility ro activate slideshow via link on page even if slideshow autostart is disabled?

Best regards
Andreas
Reply
Any idea to get the page snippet "(% gallery name=galleryname%)" working together with Simple Input Tabs?
It just outputs the plain text…
Reply
Hello,
I was wondering if there is a way to sort the images into a gallery by filename, filesize, fileweight, etc.
I know there is the possibility to drag-and-drop but I think it could be very useful for long list, frequently updated, of images (such as in a press-review gallery, for example).
If this shouldn't be possible from the backend, perhaps it would possible with an output parameter.
I am sorry if this has been already answered but a search on the forum didn't get any result.
Thank you!
Reply
noticed 2 problems.

php errors in pic.php break output
spaces after closing tags in gsconfig break output as well

minor issue, but you can probably fix by overriding php error reporting after common, or adding output buffering to it.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
Is there a code snippet to show recent photos in sidebar? like 1-5 photo with slider or something with link to gallery Angel
Reply
hi All
i installed this plug in , everything works fine except i don't get the fancybox
if i click on a image it just plops open in the browser

do i miss something ?
i use GS 3.3.6
tested it in the Lucid theme (has also included some js)
have added <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
tried to use the plug in with and withoutenabling the js in the settings from this plug in
but run out of ideas what it can be
does someone maybe has any idea ?

many thanks
Reply
(2015-08-17, 03:17:23)maco-nl Wrote: have added  <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>

Did you try a lower version of JQuery? 1.7.x or 1.8.x should work.
Reply
(2015-08-17, 03:47:40)vallhund Wrote:
(2015-08-17, 03:17:23)maco-nl Wrote: have added  <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>

Did you try a lower version of JQuery? 1.7.x or 1.8.x should work.

thanks for the info ,
will try it , think the lucid theme has also 1.8 
but will look for googleapis

let you know the result

EDIT : To bad also no luck ,, tried them all prettyhoto , fancybox etc but still no fancy just popping up picture 
cycle doesn't even work 

EDIT 2 :
installed a clean GS 3.3.6 and installed this plugin and works Confused
so need to figure out if it is a other plugin or the theme what is messing arround 
or it has to do with friendly urls ,, will check double check

EDIT3:
Found the problem 
in the theme you got a jquery-1.8.3.min.js 
deleted this one and this plugin works like a charm
Reply
Hello, I was wondering is there a way to make it so that when you're adding new photos to an existing gallery, they are added to the beginning instead of the end so you don't have to drag and drop them individually in order to show the newest photos first? 

Any ideas? I welcome any suggestions or input - my client is getting frustrated because they have hundreds of photos in a gallery and they have to show newest first. Thanks in advance!
Reply
Hello,


How to make a grid of 3 columns of photos or 4 columns of photos and center them? Because by default the right margin between the gallery content and the parent content div is more than left margin and all the gallery floated left and looks ugly.


Is it possible to set width in % instead of pixels?
Reply
(2013-11-20, 10:29:29)stryker Wrote: Hello,

I am using bootstrap 3 and just want to CENTER the whole gallery (Prettyphoto) inside the parent container / div / column. I've tried for ages to change the relevant CSS styles but stubbornly the gallery always seem to float / align left.

Best case solution would be the thumbnails appearing evenly over the width of the parent container and this would happen on all viewports but I would settle for centering the .gallery style or similar.

I don't mind adding another div that surrounds it if this would be a good solution.

I have tried the tip on post 991 of this thread but each thumbnail appeared on it's own row and not what I was wanting.

Have spent numerous hours on this and thought I would ask the expert Smile
Thanks

I'm also looking for the solution
Reply
(2013-11-20, 16:47:21)mvlcek Wrote:
(2013-11-20, 10:29:29)stryker Wrote: I am using bootstrap 3 and just want to CENTER the whole gallery (Prettyphoto) inside the parent container / div / column. I've tried for ages to change the relevant CSS styles but stubbornly the gallery always seem to float / align left.

You just have to make your own rules more specific than the generated rules, for CSS rule precedence see e.g. http://www.vanseodesign.com/css/css-spec...-cascaade/.

It helps if you have multiple IDs in your template e.g. <body id="body"> <div id="content"> and then specify the rule as #body div#content ... { ... }. You can look at the developer tools of your browser to see in which order the CSS rules are applied.

It's strange that by default the Gallery aligning left and does not have the option to change it because most of the galleries in the world aligning center and this is very logical. Aligning left gallery looks ugly. Nobody like this look.
Reply
This works for me

div#your_container_for_gallery .gallery-prettyphoto {
text-align: center;
}

div#your_container_for_gallery .gallery-prettyphoto .gallery-thumb {
float: none;
display: inline-block;
}
Reply
Hi, I LOVE your gallery and have used it before on another website.  This time I am having problems though and I don't know why.  The gallery displays, but doesn't start automatically.  I chose "cycle" with the "dots" nav.  This works great on my other site, with the same configuration, but on the new one, I don't see the "dots", just buttons that show up on hover, and the slides don't run unless you click them manually.

I have tried uninstalling, reinstalling, redownloading, changing the code, including putting the component code into the page html itself rather than in the template.  Tried putting the auto start code into the header and the template.  Tried turning off JQuery and CSS, and each individually.  Nothing seems to be working.  I'm sure I am overlooking something, but even comparing side by side with the working site, I can't see what the difference is.  Any help will be greatly appreciated.
Reply
Hello,

Does anyone know why the images in this gallery
http://salonmirifique.ro/test/colectii-cosmetica/
are moved to the right when hover the mouse over the first 2 rows of images?

Thanks
Reply
I found it.

It was a css problem from the theme. It was something over links a:hover.
Sorry for disturbing.
Reply
Hi. Thank you for an interesting CMS and Galley plugin.

Trying to make the I18n Gallery plugin work, which it does, but I have some small issues with the plugin.

First, the thumbnails are not rotated via exif. What can be done about that? Is exif in play here?
Second, when I first made it work, the image view was rotated correctly when viewing from the thumb, even when I click a thumbnail which is not rotated, the image shows up rotated. After some fiddling with the different settings, back and forth, the images are no longer rotating as before, or as they should. Are there any issues with the rotation according to exif? How to rectify?

Also, when I import photos, additional photos do not show up after I save the galley. Say I have four (4) different folders with images, I import from the first and second folder, they import just fine, I save, then when I choose to add images from the third folder, they are not shown in the list after I save the gallery even though they show in the list before I save. It's like that I can import and show a certain amount of pictures, lets say a 100, but if I add additional pictures afterwards they are just ignored. Something you have noticed?

Is the gallery plugin optimized for the latest release?

Thank you so far.

FAFDK
Reply
(2015-09-18, 01:49:24)fafdk Wrote: First, the thumbnails are not rotated via exif. What can be done about that? Is exif in play here?

Exif information is lost when generating the thumbnails. Make sure to have the images rotated correctly before using in the gallery.

(2015-09-18, 01:49:24)fafdk Wrote: Also, when I import photos, additional photos do not show up after I save the galley. Say I have four (4) different folders with images, I import from the first and second folder, they import just fine, I save, then when I choose to add images from the third folder, they are not shown in the list after I save the gallery even though they show in the list before I save. It's like that I can import and show a certain amount of pictures, lets say a 100, but if I add additional pictures afterwards they are just ignored.

PHP places a limit on the number of POST variables, see e.g. here for a description on how to increase this.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
(2015-09-21, 03:53:32)mvlcek Wrote:
(2015-09-18, 01:49:24)fafdk Wrote: First, the thumbnails are not rotated via exif. What can be done about that? Is exif in play here?

Exif information is lost when generating the thumbnails. Make sure to have the images rotated correctly before using in the gallery.


(2015-09-18, 01:49:24)fafdk Wrote: Also, when I import photos, additional photos do not show up after I save the galley. Say I have four (4) different folders with images, I import from the first and second folder, they import just fine, I save, then when I choose to add images from the third folder, they are not shown in the list after I save the gallery even though they show in the list before I save. It's like that I can import and show a certain amount of pictures, lets say a 100, but if I add additional pictures afterwards they are just ignored.

PHP places a limit on the number of POST variables, see e.g. here for a description on how to increase this.

OK. Thank you for your answer. I will look at it. thx again.
Reply
Hi,

Make it with different languages (titel) e.g check everything but display only in the default language, wath can i do wrong or forget?
Reply




Users browsing this thread: 3 Guest(s)
Free HDTV Channels Residential Solar Panels