Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I18N Gallery
(2016-02-22, 02:35:33)Dannie Wrote: My GetSimple works fine, but now I wanted to add the i18n Gallery plugin, but gets this error from my FTP server:

Copying files to remote side failed.
Virus Detected and Removed: Atomicorp.PHP.fopen.htaccess.2010121601.UNOFFICIAL
gallery.class.php: Operation not permitted

I am using this plugin at another site (at another hosting provider), without any problems.

It's not a virus: the plugin creates a directory i18n_gallery in the  data and the backup directories and adds .htaccess files with "Deny from all". As this is not really necessary (as data and backup already have such .htaccess), you can just remove the respective code from function checkPrerequisites in i18n_gallery/gallery.class.php:

Code:
public static function checkPrerequisites() {
    $success = true;
    $gdir = GSDATAPATH . I18N_GALLERY_DIR;
    if (!file_exists($gdir)) {
      $success = mkdir(substr($gdir,0,strlen($gdir)-1), 0777) && $success;
    }
    $gdir = GSBACKUPSPATH . I18N_GALLERY_DIR;
    // create directory if necessary
    if (!file_exists($gdir)) {
      $success = @mkdir(substr($gdir,0,strlen($gdir)-1), 0777) && $success;
    }
    return $success;
  }

Additionally you can also manually create these files.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
@mvlcek


Would you mind replying to me as well?

Thank you
Reply
(2016-02-22, 09:39:58)keneso Wrote: @mvlcek


Would you mind replying to me as well?

Thank you

The site (currently?) does not use I18N Gallery and I don't know, how you include the tabs. But at least with Photoswipe it seems that the javascript files (and the CSS files) are include multiple times, which will most probably cause problems.

With I18N Gallery you can include multiple galleries on one page, if they are specified in the content of the page with (% gallery ... %). If you include the content of multiple pages via the template or if you include galleries via get_i18n_gallery(...) in the template, it probably won't work.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
(2016-02-22, 17:38:13)mvlcek Wrote: The site (currently?) does not use I18N Gallery and I don't know, how you include the tabs. But at least with Photoswipe it seems that the javascript files (and the CSS files) are include multiple times, which will most probably cause problems.

With I18N Gallery you can include multiple galleries on one page, if they are specified in the content of the page with (% gallery ... %). If you include the content of multiple pages via the template or if you include galleries via get_i18n_gallery(...) in the template, it probably won't work.

Thank you for the reply.

My apologies for not having given you the full path:
afzdesign dot com/demo/fioriera/gs/index.php?id=gallery

If you please click on the 3 tabs "fioriera bianca 38", "fioriera ciliegio 75", and "fioriera rovere 202" you'll see that I am using I18NGallery.

I have tried both options, using (% gallery ... %) on the page, and get_i18n_gallery(...) on template file.

Like said I tried Fancybox, and Prettyphoto as well, and issue is there, to be precise, I could not have the latters work even with a single gallery.

Yes, though not a coder, first thing I thought of was a js conflict, would you have any idea how to solve it?
I've set up an ftp account for you, if you'd like to kindly take a direct look, I'll PM you details.

Thank you
Reply
Hi  mvlcek

Have you any plans for making the i18n Gallery work with later versions of JQuery ?

I notice the gallery uses jQuery 1.4.3, which was released in Oct 2010  The latest version today is 1.12.1.  Yes, you can disable the insertion of the gallery’s 1.4.3 and insert your own. But people could start to have problems where they have other functionality on a page which only works with a later version, but then the gallery does not work with this later version.

For me, I am doing a website where I want to use jquery-color latest 2.1.2  to fade the colour of a menu on hover, and also have the gallery on a page. The gallery Fancybox does not work with 1.11.3 (the latest I checked with, also I did not check with a version between 1.4.3 and 1.11.3).  But luckily my menu color fade seems to work with 1.4.3  .. so at the moment I don’t have a problem,  but there could be problems in the future   …

I see that the I18n Gallery plugin is a wrapper for all the enclosed individual 3rd party galleries/sliders  like Fancybox and Prettyphoto  .. So the plugin is really great for multilingual captions - which this individual components cannot do, and easy image set up in the backend and then definition in the frontend.   I also see that you have described how to Extend it, eg add other galleries/sliders  .. eg newer ones,  (which may be also better at being responsive  .. also very useful these days)  like Fancybox 2    ..  But my problem is that I’m not very good at PHP ( ..yet )   It would by a shame for the plugin to become less and less usable  as it stands ...  

Cheers Aldebaran      
Reply
(2016-02-25, 02:02:47)aldebaran Wrote: Hi  mvlcek

Have you any plans for making the i18n Gallery work with later versions of JQuery ?

I notice the gallery uses jQuery 1.4.3, which was released in Oct 2010  The latest version today is 1.12.1.  Yes, you can disable the insertion of the gallery’s 1.4.3 and insert your own. But people could start to have problems where they have other functionality on a page which only works with a later version, but then the gallery does not work with this later version.

You should update I18N Gallery.
Since version 2.2 (April 2015) I18N Gallery uses jQuery 1.11.2 and probably also works with jQuery 1.12.1.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
Oops sorry my fault .. I misread between v211 and v221. All good

Aldebaran
Reply
Hello,

In spite of the warnings ( Blush ), I want to show a gallery in search results, using custom Search View code.

Everything is working correctly, except that the Title and Description of the gallery is ignoring the current language. The base language ('en') always shows, even when the browser language is 'fr' (either from the browser preferences or from setlang='fr').

Is there any way to force the language with the get_i18n_gallery call, please?

I am prepared to duplicated and customise built-in I18N-* functions, if necessary, to allow the language to be passed to a get_i18n_gallery call either in the Search View or in a component.

Thanks.

Edit: Having moved to the production site, everything seems to be working now. Maybe a cache problem or server parameter, but I don't know for sure.

Sorry for the noise.
--
Nick.
Reply
Hi guys,

I am having some trouble using multiple I18N Galleries on the same page. I am using I18N OnePage to display subpages, each containing one I18N Gallery.
Now, all the galleries are displayed, so that's good. However, the first gallery seems to work differently. That's to say, the images in the first gallery link directly to the original uploaded image, even when I enable jquery and css from the Galleries options.
In the all the other galleries the images have a link form of ...?pic=image-name:-image number (as in 1, 2, 3) . Clicking those links seems to take me to automatically generated page that uses my default template. That page does display the image and the prettyphoto slider.

I have no idea why this is happening. I have removed all other scripts from the site. When I have a single gallery on the page, it behaves like the described first gallery.

Any help in this matter would be appreciated.
Reply
I'm having issues with this plugin after moving my website. The problem is broken thumbnails. Even though I've cleared the cache and thumbnails within the plugin and GS, it won't show up properly.
Reply
Hello there, i have a conflict if i try to show hidden content using I18N Gallery.


I'll explain whati need to do, i will create some hidden galleries who revealed on click.
In the editor everything works if i put a code like this:


Code:
<script>
function show(div, contents)
{
  document.getElementById(div).innerHTML = contents;
}
</script>
<p><a href="#" onclick="show('mydiv1', 'hidden content')">Show Content</a></p>
<div id="mydiv1">Click to show hidden content</div>

But, if i put gallery shortcode (% gallery%) instead hidden content the result is corrupted, the output show the gallery without click.

How can i fix it?
Best
Reply
(2016-04-19, 00:58:48)lakaroth Wrote: Hello there, i have a conflict if i try to show hidden content using I18N Gallery.


I'll explain whati need to do, i will create some hidden galleries who revealed on click.
In the editor everything works if i put a code like this:




Code:
<script>
function show(div, contents)
{
  document.getElementById(div).innerHTML = contents;
}
</script>
<p><a href="#" onclick="show('mydiv1', 'hidden content')">Show Content</a></p>
<div id="mydiv1">Click to show hidden content</div>

But, if i put gallery shortcode (% gallery%) instead hidden content the result is corrupted, the output show the gallery without click.

How can i fix it?
Best

My guess is that the output from (% gallery %) includes unescaped characters that break the Javascript string (like ').

An alternative approach is to wrap the (% gallery %) in a div that is initially hidden (and whose class/id is known), and bind the click event to the link after the page has loaded:

Code:
<p><a id="show_gallery_link" href="#">Show Content</a></p>
<div id="hidden_gallery" style="display:none;">(% gallery %)</div>

...

<script type="text/javascript">
// When the document has loaded...
document.addEventListener('DOMContentLoaded', function() {
  // ...bind the click event to the anchor...
  var a = document.getElementById('show_gallery_link');
  a.addEventListener('click', function() {
   // ...which shows the gallery
   document.getElementById('hidden_gallery').style.display = '';
   return false;
  });
});
</script>

If you have jQuery loaded, the Javascript code can look a little more concise:

Code:
<script type="text/javascript">
// When the document has loaded...
$(document).ready(function() {
  // ...bind the click event to the anchor...
  $('#show_gallery_link').click(function() {
    // ...which shows the gallery
    $('#hidden_gallery').hide();
    return false;
  });
});
</script>
Reply
I'm having an issue with the I18N Gallery where if I place the shortcode on a page (sidebar) and the template page has getcontent from the page of that sidebar, the gallery will not load. It will only show the shortcode for it. (% gallery name=portraits-gallery %)

On my portfolio template page I have:

Code:
<div class="sidebar-left">
   <?php getPageContent(return_page_slug().'-sidebar'); ?>
</div>
<div class="content">
   <?php get_page_content(); ?>
</div>
Reply
1. Is there a limit to how many characters can be saved in the Description Field?
2. Is there any way to have a rich text editor in the displayed Description field?
Reply
Hi mvlcek


I have done a new gallery type here  for i18n Gallery. It is a wrapper for nanoGallery  which is a cool looking, mobile friendly,  fully responsive and  with swipe action and slideshow support.   I do not support in this version all your / general i18n Gallery config nor  all possible nanoGallery config, as you will read. But I will add some more in a later version hopefully.  If you have any feedback, if I am doing anything wrong, that would be great to know.

Cheers Aldebaran

 
Reply
(2016-05-04, 06:42:03)newdeepdan Wrote: I'm having an issue with the I18N Gallery where if I place the shortcode on a page (sidebar) and the template page has getcontent from the page of that sidebar, the gallery will not load. It will only show the shortcode for it. (% gallery name=portraits-gallery %)

On my portfolio template page I have:




Code:
<div class="sidebar-left">
   <?php getPageContent(return_page_slug().'-sidebar'); ?>
</div>
<div class="content">
   <?php get_page_content(); ?>
</div>

You can try forcing the content filters to be executed:

PHP Code:
<?php
// Get the (sidebar) page content as a string
$sidebar returnPageContent(return_page_slug() . '-sidebar');

// Execute the filters
$sidebar exec_filter('content'$sidebar);

// Print the result
echo $sidebar

(not tested)

Wrapped up in a function for you:
PHP Code:
// Example usage: get_page_sidebar(return_page_slug());
function get_page_sidebar($slug) {
  
$sidebar returnPageContent($slug '-sidebar');
  
$sidebar exec_filter('content'$sidebar);
  echo 
$sidebar;

Reply
Hi,
Im trying to create gallery with 230 photos. I load photos, but when i click Save Gallery, everything is lost a I see blank dialog for creating new gallery.
Is there a limit for number of photos?

Thank for reply
Libor Marek
  
Reply
I was able to create a gallery of 120 photos.
Reply
check error log, I had some problems with i18n_navigation and it was because of php memory limit, as 230 is a pretty big number resulting in a complex xml file (and then second time it was only corrupted cache file..)
Reply
Same here, can't save the galery after adding images. The script runs, but no confirmation appears (yellow infoblock at the top) and the images aren't added.

The server log:
---------------

[Sun Jun 19 11:15:43 2016] [error] [client 145.133.160.212] File does not exist: /web/WebSites/d/l/e/o/XXX.at/htdocs/plugins/i18n_gallery/js/+d.titlePosition).html(s).appendTo(
[Sun Jun 19 11:15:43 2016] [error] [client 145.133.160.212] File does not exist: /web/WebSites/d/l/e/o/XXX.at/htdocs/plugins/i18n_gallery/js/:m.html(e.content);F();break;case
[Sun Jun 19 11:15:43 2016] [error] [client 145.133.160.212] File does not exist: /web/WebSites/d/l/e/o/XXX.at/htdocs/plugins/i18n_gallery/js/;m.html(

*** > Update to the current GetSimple-Version ***

[Sun Jun 19 21:31:21 2016] [error] [client 91.248.90.100] (103)Software caused connection abort: Failed to flush CGI output to client, referer:

----------------


Also flushed the Cache (via backend-option).

Any ideas what I can do?

Thank you very much!
Reply
Has anyone else had an issue with galleries scrolling to the top of the page when the thumbnail is clicked? I'm having this issue with both Fancybox and Prettyphoto. I have tried every fix available on Google to no avail, tried installing the newer version of Fancybox and updating the CSS as per online fixes. I've even consulted with a friend who is good with jQuery (I'm useless with it) but to no avail. Can anyone help with this please? I've just reinstalled i18n gallery from scratch as none of the fixes helped at all. None of the other available galleries for GS have the functionality I need i.e. block galleries with titles under, and I want the user to be able to manage the gallery themselves without coding. There are five separate galleries on the page but even using one gallery on a page causes the scrolling.

Thank you so much to anyone who can help. Smile

http://www.alloneword.co.uk/index.php?id=our-team
Reply
this line in the template
Code:
<script src="http://code.jquery.com/jquery-latest.min.js" type="text/javascript"></script>
place higher than
Code:
<?php get_i18n_header(); ?>
Reply
Thank you Oleg. It didn't work though!
Reply
it must be something with jQuery, as there are only errors for `$` not defined (maybe because of the noConflict defined?). also I would remove jQuery Migrate plugin as it's meant for development (shows recommendations for migrating from jQuery 1.x to 2.x or 2.x to 3.x)
Reply
(2016-07-20, 09:03:59)morvy Wrote: it must be something with jQuery, as there are only errors for `$` not defined (maybe because of the noConflict defined?). also I would remove jQuery Migrate plugin as it's meant for development (shows recommendations for migrating from jQuery 1.x to 2.x or 2.x to 3.x)

Thank you Morvy.  I've deleted the migrate file but it's still not working.  I don't know how to fix the noConflict thing.  jQuery is not my friend.
Reply




Users browsing this thread: 2 Guest(s)
Free HDTV Channels Residential Solar Panels