Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forum login changes?
#1
Hello,

Firefox is no longer able to auto-complete the login form for get-simple.info since yesterday (2011/05/09), has something changed?

Previously, the username field was not filled, but that was only a minor thing. Now, neither the username nor the password field is completed. I don't have this problem with any other site.

I deleted the stored password record for get-simple.info and logged in again. Now, FF doesn't even offer to save the login details for the site.

Additionally, if I select 'Remember me', the site still doesn't log me in automatically. Scripts and cookies are enabled.

I have just tried 'Remember me' in two other browsers and it doesn't work there either. That's Iceweasel (Firefox) v3.5.16, Epiphany v2.30.6 and Chromium (Chrome) v6.0.472.63 (59945), all under Debian 6. There have been no recent updates that might have caused this, afaict.

Is it just me?
--
Nick.
Reply
#2
Nick,
I noted that as well, but assumed that it happened because I changed my computer...

I will try these steps:

- clear my browser cache
- delete stored password in browser
- log in and store password anew in browser

let's see if that works

PS: I think it is because this translate.google.com - API takes so long to load ... so the page is never loaded completely (just my idea)
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#3
Connie Wrote:let's see if that works

PS: I think it is because this translate.google.com - API takes so long to load ... so the page is never loaded completely (just my idea)
It didn't work for me.

It seems to make no difference if scripting is enabled or disabled, so I don't think it's due to Google (though I agree, it frequently fails to load). The result is the same even if I wait for all the scripts to load.
--
Nick.
Reply
#4
For info: I use Chromium (win32) and autologon still works.
Reply
#5
Under FX4.01 everything works fine.
Have you tried on other website's BBS-es ?
It doesn't have to be actually a browser problem, but ISP's transparent proxy or other network problems.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#6
i am messing around with changes to this forum to help try and stop spam. sometimes its a tight line to walk... if something is broken, let me know and I will try and fix it. These damn spammers are getting more and more creative.

BTW: I am not seeing the problems listed above...
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#7
Chris,

did you update the Forum-Software? At www.cmsmadesimple.de this happened after an update ... but there it helped to change Firefox-Cookie-Policy

to

userdefined rules - accept thirdparty cookies - until they are not valid

but this definition was activated in my FF without effect on get-simple.info

it's just a little bit molesting... to type the pw again and again

cheers, Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#8
nope - no forum software updates except for a few spam prevention plugins installed.
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#9
Connie Wrote:userdefined rules - accept thirdparty cookies - until they are not valid

I advise not to accept 3rd party cookies.

CC: the question is if scripts can pass through security captcha when they register accounts (did you look at statistics of acc registering page ?)
You can't prevent from incoming spam posted by living "creatures".
Addons: getsimple theme, Online Visitors, Notepad
Reply
#10
yojoe Wrote:You can't prevent from incoming spam posted by living "creatures".
unfortunately. as for the 3rd party cookies - I don't think it's something i can turn off inside PunBB.
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#11
Well, I can see that the browser has 7 get-simple.info cookies set, plus the PHPSESSID and a couple from Google.

If there isn't something in there that includes login information ...

This is with the browser wide open – no script protection and all cookies accepted. I won't be running like that for long. The autocomplete previously worked fine without third-party cookies and site cookies for the session only; very limited script permissions.

I have never used the site 'Remember me' feature, preferring to have the browser fill in login credentials. Now that neither (semi-)automatic login is working, it's very inconvenient when using a reasonably secure password.
--
Nick.
Reply
#12
CC: I had on my mind turning off 3rd party cookies in browser, not in a webapp Wink

Hameau: why don't set a master password for whole browser profile, and store login/pass for websites ?
Addons: getsimple theme, Online Visitors, Notepad
Reply
#13
yojoe Wrote:Hameau: why don't set a master password for whole browser profile, and store login/pass for websites ?
That's what I normally do. That's what stopped working, but only for get-simple.info. Then, when I tried having the site set a cookie to 'Remember me', that doesn't work either.
--
Nick.
Reply
#14
I encountered such problems with FX.
It may be related with broken history, and links dbase, cache and so on.

Did you try with creating a fresh test profile ?
Otherwise I'd delete manually all files from /profile/cache except cache config file (don't remember its name because I turned off file caching on disk, and use memory cache), renaming places.sqlite to see if history dbase isn't messed up.

And of course delete manually all cookies related to GS, punbb and google.
Addons: getsimple theme, Online Visitors, Notepad
Reply
#15
yojoe Wrote:Did you try ...
Yes, all of those. And Firefox in a Windows XP virtual machine – always the same result.

It's a mystery.
--
Nick.
Reply
#16
I'm not getting any "Do you want to store your password?" questions either in Firefox 3.6 (Ubuntu and Windows). The "log me in automatically" still works, though - however, I let the browser clean all cookies on exit, so it doesn't help much.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
#17
I updated FF recently to FF 4 and the problem continues....

It could be a forum spam plugin which prevents logging in with "inherited" cookies, maybe?
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#18
Connie Wrote:It could be a forum spam plugin which prevents logging in with "inherited" cookies, maybe?
I'm fairly sure that it's a recent anti-spam measure, but there are at least two aspects to this:
  • FF stored passwords is disabled by this site;
  • the site's own persistent login feature ('Remember me') no longer works.

I'm very surprised that so few people are (apparently) affected.

Incidentally, the Wolf CMS forums are also based on punBB, integrated into the support site; I can still log in automatically there. Both sites serve a broadly similar market, so should attract similar levels of spam and nuisance posts. However, there are 967 registered members on wolfcms.org and little visible spam, 3.771 here and a rather visible spam presence. Now, 3.500+ plus members in two years (I think) on any specialist support forum seems like a lot.

Not a scientific comparison, but some informal dialogue between admins on the two sites might be useful ?
--
Nick.
Reply
#19
hameau Wrote:Not a scientific comparison, but some informal dialogue between admins on the two sites might be useful ?

yes, this is useful, thanks!
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#20
Whatever it was, thanks for fixing it! (Y)

Firefox has saved the login credentials and has successfully auto-filled the form, so it's actually better now than it has ever been (both username and password are automatic now).

Move along now, nothing more to see ...
--
Nick.
Reply
#21
Yes, it works again.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Reply
#22
for me too, I was really surprised that I was logged in so fast suddenly ... funny
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#23
ok, so it was definitely the new anti-spam plugin i tried. connie - hopefully we dont see much more spam because of it....
- Chris
Thanks for using GetSimple! - Download

Please do not email me directly for help regarding GetSimple. Please post all your questions/problems in the forum!
Reply
#24
My Fire fox doing same thing,not able to auto fill. Will this change with new 4.0.1?
Reply
#25
ccagle8 Wrote:ok, so it was definitely the new anti-spam plugin i tried. connie - hopefully we dont see much more spam because of it....

yeah, now we have a dilemma - more comfort + eventually more spam or less comfort but less spam ...

;=)

we will see
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply




Users browsing this thread: 1 Guest(s)