Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MLD email newsletter plugin
#1
MLD newsletter plugin for GetSimple v0.1 (beta)

The MLD newsletter plugin adds full e-mail newsletter functionality to your GetSimple website. Let visitors subscribe to your newsletters and keep them informed aboutt your work or business.

Features
  • Visitors can subscribe or unsubscribe themselves to your letters.
  • Subscription must be confirmed by clicking on link in email.
  • You can manage the subscriptions trough the admin panel.
  • Create a template for the header and footer of your letters.
  • Test send your newsletter to yourself before sending it to the world.

Requirements
This plugin needs the squareit-loadtab plugin to function, which provides support to display a new tab in the admin panel.
Download squareit-tabloader: http://www.smooka.com/blog/wp-content/pl...d.php?id=5

Installation
  • Download and unpack the .zip file containing the plugin.
  • Copy downloaded files to the root of your installation.
That's all.

Usage
Place the following in your template to display subscribe/unsubscribe form:
Code:
<?php mld_newsletter_form(); ?>

Download
Download below and support in this thread.
Reply
#2
this sounds very promising!

one of my clients asked for such a system once and I had to integrate an external newsletter system

I will have it on my list next time, when I find time I will test it, for sure!

Cheers, Connie
|--
Die deutsche GetSimple-Webseite: http://www.Get-Simple.de = the german Get-Simple-Website!
Das deutschsprachige GetSimple-(Unter-)Forum:   http://get-simple.info/forums/forumdisplay.php?fid=18
Reply
#3
just install the squareit-tabloader but i dont know how to edit it.

for the MLD newsletter plugin, how to access the admin panel?? is this a stand alone software~
Reply
#4
Just place the squareit-tabloader in the plugins folder. You don't have to edit anything. The admin panel for MLD newsletter should be available if you have both plugins installed.

Which GetSimple version do you have? It's tested with v3.0.
Reply
#5
The subscribe form from the front end works fine. But after submitting it appends the text

pl
Array

just above the Name field. Why does this happen?

Also, I'm unable to send email newsletters with this error message showing.

Failed to send newsletter to subscribers

My email newsletters were going fine through Mass Mail Newsletter plugin but theri front end subscribe form broke my template. Also, your plugin has more options and I definitely want to use this so please help me out with the send newsletters error.
Reply
#6
Currently I'm working on a updated version with more detailed error messages. There will also be more features available. Hopefully it will solve your problem. It will be available in a few days.
Reply
#7
leenm Wrote:Currently I'm working on a updated version with more detailed error messages. There will also be more features available. Hopefully it will solve your problem. It will be available in a few days.
leenm Wrote:Currently I'm working on a updated version with more detailed error messages. There will also be more features available. Hopefully it will solve your problem. It will be available in a few days.

Great. Can't wait to get my hands on it.
Reply
#8
Hi Leen, great plugin.
I have started testing it. Same problem as andyash with that "Array" code above the sub / unsub public form.
The rest of the plugin works but I can not insert tables, images and special characters into newsletter text, header and footer.
I guess it is a general problem with encoding / decoding but I can't find where it hides.
Also, it may be a bit too soon nevertheless I have translated the existing strigns into french, see below.
Cheers.

edit 03/12/2011: I ran some tests with it, think some fields need CDATA enclosures (at least <content> field).
Reply
#9
calmos Wrote:edit 03/12/2011: I ran some tests with it, think some fields need CDATA enclosures (at least <content> field).
You're right about that, it's one of the improvements in the next version. Thanks for translation, I'll include it in the next version.

Unfortunately development is not going as fast as I wanted, mainly because 7 days in a week is not enough to finish all my regular work. I'll try to finish by the end of this year, somewhere around the holidays I will have some spare time.
The plugin will need GetSimple 3.1, so I'll try to release after 3.1 is available.
Reply
#10
New version available, added the plugin to Extend. GetSimple 3.1 required: Link to extend
Reply
#11
When I uploaded the files, when I went to my site I was getting a 500 error. When I deleted them, my site worked again. Is this just me or has anyone else been having this problem?
Reply
#12
matthewdickens Wrote:When I uploaded the files, when I went to my site I was getting a 500 error. When I deleted them, my site worked again. Is this just me or has anyone else been having this problem?
why don't you place a conditional statement adding a sidebar link if square-it is not installed
Reply
#13
Quote:adding a sidebar link if square-it is not installed
It won't work with square-it without modification. I've removed the square-it tabloader, because GetSimple 3.1 will be available soon (At least, that's what I think Smile. Maybe I'll add some backward compatibility when it's taking to long. There are a few other thing's I've to change / improve anyway.

EDIT: next version will be GS3.0 compatible. Will probably be available today or tomorrow.
Reply
#14
Updated the plugin. Changes:
- compatible with GS3.0
- changed back to swiftmailer email class, because batch sending didn't always work with phpmailer.

Download: http://get-simple.info/extend/plugin/mld...etter/310/
Reply
#15
Hi,
thanks for the plug-in.
I'm installing it on a GS 3.0 and it seems to be all right, but when I try to add an image in the header or foot it saves as: <img alt="\&quot;\\&quot;\\&quot;\&quot;" src="\" />

What can I do to make it work with images?

Thanks
Luis
Reply
#16
Where is the image located? Did you upload the image to GetSimple first? The plugin uses the GetSimple filebrowser to browse the GetSimple files.
Reply
#17
Hi,
thanks for your quick answer!!

Well I was trying with an image form web (passing an URL), and the plug-in can't get it.

Now, after your answer, I tried to upload the image with the GS filemanager and insert the image on the plugin ("newsletter settings").
At first it seemed ok, because I can see the image on the header.
But when I pressed "save settings" it disapeared (!).

I try then to send the newsletter anyway, and I receive something like this:
<img alt=3D\"test image\" src=3D=
\"http://<my_GS_CMS>/data/uploads/logo.png\" style=3D\=
"border-top-width: 0px; border-right-width: 0px; border-bottom-width: 0p=
x; border-left-width: 0px; border-top-style: solid; border-right-style: =
solid; border-bottom-style: solid; border-left-style: solid; width: 242p=
x; height: 107px; \" />

So it's almost there Undecided
I think the problem is that it's adding that 3D thing (maybe it's a new plug-in dimension ;-)

it's there something I can do to help you help me? I mean some kind of debug, some log...

Thank you very much.
Luis
Reply
#18
It seems like a specific problem in your situation, when I tested it the plugin worked fine in GS3.0. I don't know why the 3D stuff is added, I'll look into it.
Try and enable debugmode and see if there are any errors. (http://get-simple.info/extend/plugin/debugmode/130/ is a useful plugin)
Reply
#19
Hi leen,
thank you again.

I'm going to try the debug plug-in and comment what I found.

Thank you very much.
Best Regards
Luis
Reply
#20
Hi,
I have good news... it works :-)

So I was searching for the problem, I activate debug and I found a couple of weirds things.

First, (but it finally have nothing to do with my problem), if I use debug and activate MLD newsletter, it claims:
Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'addStyleBC' was given in /.../admin/inc/plugin_functions.php on line 191

I found that when the plug-in is called (mld-newsletter.php) the variable GSVERSION is not set, so the first condition
if (GSVERSION == 3.0)...
it's always false and doesn't include compatibility.php
As my GS version is 3.0 I tried to comment off the if condition so I forced to include compatibility.php and the warning disapeared.

But still, nothing to do with my problem.

I found that in some places of the plugin, when it loads the content or header or footer, the string has backslashes that must not be there.
So I tried to wrap the load functions with stripslashes() and ¡¡it works!!

Seems that the 3D thing is added on the mail. I'm not pretty sure if its the mail sender or the client, but it's not in the message for sure.
When the string is correct (without the backslashes), the 3D it's gone too.

So I *supose* that there's some configuration on my PHP server that misslead to the slashes thing.
So the fine way to improve the plug-in would be to check for this hypotetical configuration variable and then use or not the stripslashes() function.
For now, for me, I have simply added the function and it works.

I attach the patch.

Thanks again to Leen, and to every body at GS.
Regards
Luis
Reply
#21
Thanks Luis, I'll implement the patch in the next update. (which is probably today or tomorrow, since the 'create new newsletter' button didn't work in the latest version).
Reply
#22
Yeah, I just notice it :-)

Thanks for your work.
I'll wait for the new version.

Best Regards
Luis.
Reply
#23
Update
Updated the plugin, added some features and fixed a few issues. Download and more info: http://get-simple.info/extend/plugin/mld...etter/310/
Reply
#24
Hello,
I found some problems in the new version.

For instance, in the "subscribe" function when a user tries to subscribe, the system uses the data from the user before. This also causes that the first user subscribing founds an error.

Also if the form is not in the main page, the url contains two '?', one from the url of the page an another generated by the form.

I attach a patch that fixes these two things.

Regards
Reply
#25
Hi,
found another one :-)

Function email_confirm doesn't save the confirm status.

I attach the patch.

Best Regards
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels