Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updater - keep your GetSimple installation and plugins up to date
#26
Hi mvlcek,

after enabling both of them, at least for I18N the check does work, for base not as you said.

I18N Base 3.0.5 Upgrade Check Failed ! 3.0.5
I18N 3.0.5 3.1 Upgrade Recommended 3.1

Ok, the updater check now works again. Many thanks to all that helped!!!

But(...) i have a new problem:
The update functionality itself does not work. The updater flaggs some updates as necessary and when click "Update all Plugins" it obviously tries to download the zip file and unpack it. But this fails:
"Error: Unable to open file 'C:\wamp\www/data/other/updater/temp/hitcount.zip'. Unable to open file 'C:\wamp\www/data/other/updater/temp/i18n.zip'."
If i look into the updaters temp folder i can see that it made new subdirs with the name of the plugins to update but there're no zip files.

I've no idea if it's the fault of the plugin or if there's still something strange happening on the extend server side.
Unfortunatly my web/php knowledge is still too basic to be of real help here.

THanks again to all you helpful folk at GetSimple!

Holger
Reply
#27
@hd, sorry forgot to change 1 thing. Its fixed now , but again you must wait for the files to recache
My Github Repos: Github
Website: DigiMute
Reply
#28
Now the actual update works as well, just as you've promised!
Many thanks again.
Reply
#29
bump this again, FYI
if you are not seeing the icon images, it is because this plugin is missing an allow all htaccess file in the icons folder
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#30
I just spent hours figuring out why this would not work on a specific host, still no damn clue why.

But CURLOPT_FILE was not being set whenin an options array.
I had to explicitly add
curl_setopt($ch, CURLOPT_FILE, fopen($destination, "w"));
( should probably be 'wb' also for binary )

It would output the file to the screen and save a 0 length file.

EDIT:
It has to do with the order of setting FILE. I don't know how it applies options when in an array, but apparently it can make a difference depending on config of a host and what options are defaulted internally.
it works when i move FILE to the beginning of the options array in plugins.php

PHP Code:
// no worky
    
$curl_options = array(
        
CURLOPT_URL => $url,
        
CURLOPT_FOLLOWLOCATION => true,
        
CURLOPT_MAXREDIRS => 10,
        
CURLOPT_FILE => fopen($destination"w"),
    );

// worky
    
$curl_options = array(
        
CURLOPT_FILE => fopen($destination"w"),
        
CURLOPT_URL => $url,
        
CURLOPT_FOLLOWLOCATION => true,
        
CURLOPT_MAXREDIRS => 10
    
); 

ok figured that one out
curl_setopt_array returns false immediately if a setting fails to set, preventing any following settings to apply.
In my case, followlocation fails because of open_base_dir restrictions in php, and there is no error catch for this.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#31
plugin is including main.js on every page
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#32
This plugin when performing a core update, sets my .php files to 775 and my host throws 500 errors ( writable by group ), I have to drop it to 755 or below etc., Just a note for anyone else having this problem.
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply
#33
This plugin contains a continue outside of loops instead of return.
This is fatal in php7

Fatal error: 'continue' not in the 'loop' or 'switch' context in /Users/shawn/projects/web/dev/getsimple/develop/plugins/updater/inc/helpers.php on line 142
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix
Reply




Users browsing this thread: 1 Guest(s)