Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MLD email newsletter plugin
#26
Hi,
same thing, for different reason, on saving the sended status on newsletter.

Best Regards.
Reply
#27
Hi...
the two last (I think)... but I can't fix them right now:
- I can't delete a newsletter
- When I create a new newsletter I lost the send status of the older newsletter.

Best regards
Güimi
http://guimi.net
Reply
#28
Thanks Luis, I'll have a look asap.
Reply
#29
All issues are fixed. Attached is the fixed plugin file. (Will be included in the next release also)
Reply
#30
I'm having some problems with this plugin, even on localhost for testing.
it creates the form normally in the test page, but when you register, it's just a mistake, that does not load anything else after him.
the administration panel, the email was registered, but nothing was sent to the same.
As if the error was in the messages.

Quote:estou tendo alguns problemas com este plugin, ainda em localhost, para testes.
ele cria o formulário normalmente na pagina de teste, mas ao se cadastrar, ele simplesmente da algum erro, que não carrega mais nada depois dele.
no painel de administração, o email foi cadastrado, mas nada foi enviado para o mesmo.
Como se o erro fosse nas mensagens.

thx!
Reply
#31
@schluters: It is required to have a sender name, sender email, smtp server and smtp port in your settings. Do you have that? (and are they correct?)
Reply
#32
@leenm:
Yes, well I just checked my settings with the host and are all correct.
I'm doing the test on localhost and directly on the web.
Both have the same problem.
When a new user is registered, it appears in subscribers, but is not sent any email confirmation.
The error causes the entire contents that comes after the form is not displayed.
Apparently it seems that the error is in the presentation of the message on the screen.

Thank you.

Quote:Sim, acabei de verificar também com o host minhas configurações e estão todas corretas.
Estou fazendo o teste em localhost e diretamente na web.
Ambos apresentam o mesmo problema.
Quando é cadastrado um novo usuário, ele aparece nos subscribers, mas não é enviado nenhum email de confirmação.
O erro faz com que todo o conteúdo que vem depois do formulário não seja exibido.
Aparentemente parece que o erro está na apresentação da mensagem na tela.

Obrigado.

Incidentally, it is mandatory to use any encryption? "SSL or TLS."
My Host offers only "SSL".

Quote:A propósito, é obrigatório o uso de alguma encriptação? "SSL or TLS".
Meu Host oferece somente "SSL".
Reply
#33
I did some verification test. I created a new email account, I tested this account in Microsoft Outlook. Really all the settings are correct.
When I used the button "Test send to administrator." screeshot see in the error. He simply does not send and does not show anything.

Quote:Fiz alguns teste de verificação. Criei uma nova conta de email, testei esta conta no Microsoft Outlook. Realmente todas as configurações estão corretas.
Quando utilizei o botão "Test send to administrator". veja na screeshot o erro. Ele simplesmente não envia e não apresenta nada.

Again thanks for your effort in helping me.
Reply
#34
I was almost forgetting. I'm using the new version 3.1
This is a problem?

Quote:Estava quase esquecendo. Estou usando a nova versão 3.1.
Isso tem algum problema?
Reply
#35
schluters Wrote:I'm using the new version 3.1
That shouldn't be a problem, I'm using it with 3.1 also.
I understand you're using the SMTP authentication settings. Those are usually not necessary when sending email from within your webhost (using the localhost email server). From your local installation: email servers usually don't allow connections from outside, so you can't use your webhost email server for testing from localhost.

Are there any php error messages? (use the debug plugin for quick enable/disable debugmode: http://get-simple.info/extend/plugin/debugmode/130/)
Reply
#36
Oh my God!
Excuse me, do you go through all this trouble, but just discovered the error.
I went back to the beginning of this topic and started to read all.
I saw that I was not using the "-squareit tabloader." It was just install it and voila, everything is working.
Thank you for your attention!

Now I'm working on a translation into Portuguese of Brazil.

Quote:Ó meu Deus!
Me desculpe, fazer você passar por todo esse transtorno, mas acabei de descobrir o erro.
Voltei ao inicio deste tópico e comecei a ler todo.
Vi que eu não estava usando o "squareit-tabloader". Foi só instala-lo e pronto, tudo está funcionando.
Obrigado pela atenção!

Agora vou trabalhar em uma tradução para português do Brasil.
Reply
#37
When using getsimple 3.1, the squareit tabloader isn't needed. Are you using the last version of the plugin?
Reply
#38
Yes, I'm using the latest version 3.1.
But as I said, after many tests, I did not do any changes except to add the "squareit tabloader" I found the beginning of the topic.
I'll try to uninstall it to see if it still works.

Quote:Sim, estou usando a ultima versão 3.1.
Mas como disse, depois de tantos testes, não fiz mais nenhuma alteração a não ser adicionar o "squareit tabloader" que encontrei no inicio do tópico.
Vou tentar desinstala-lo pra ver ser ainda funciona.
Reply
#39
schluters Wrote:Yes, I'm using the latest version 3.1.
I mean the latest version of the plugin: http://get-simple.info/extend/plugin/mld...etter/310/
Reply
#40
Yes, I use the version 0.4 and version 0.5 I found here on the topic.
With the corrections of Luis.

Quote:Sim, fiz o uso da versão 0.4 e da versão 0.5 que encontrei aqui no tópico.
Com as correções do Luis.

Strange, very strange, now that uninstalled "squareit tabloader", the MLD is still running.

Quote:Estranho, muito estranho, agora que desinstalei o "squareit tabloader", o MLD continua funcionando.

But still I say, did not change the settings after I started the post here.
Reply
#41
So everything works now? Or are there still problems?
Reply
#42
Ok, now everything is working!
Thank you.
Now I work on the translation into Portuguese of Brazil.


Quote:Ok, agora está tudo funcionando!
Obrigado.
Agora vou trabalhar na tradução para português do Brasil.
Reply
#43
schluters Wrote:Ok, now everything is working!
That's nice to hear :-) Good luck with your website.
Reply
#44
Some things that could be implemented for next version are:

Subscriber's choice to see the newsletter directly in your browser.
Example in the message header: "If you're not viewing this email properly, click here."

Also the option to unsubscribe from the newsletter.
Example at the bottom of the message: "If you wish to cancel your registration, click here."

I'm almost finished the revision of the translation into Portuguese of Brazil.

Quote:Algumas coisas que poderiam ser implementadas para proxima versão, são:

Opção do assinante ver o boletim diretamente no seu navegador.
Exemplo no cabeçalho da mensagem: "Caso você não esteja visualizando corretamente este e-mail, clique aqui."

Também a opção de cancelar a inscrição no boletim.
Exemplo no rodapé da mensagem: "Caso você deseje cancelar seu cadastro, clique aqui."

Estou quase terminando a revisão da tradução para português do Brasil.

Thanks again!
Reply
#45
Next version available here: http://get-simple.info/extend/plugin/mld...etter/310/

@schluters: you can make your own template header and footer in the newsletter settings. It is possible to place a link to your unsubscribe form or newsletter archive (new functionality) also.
Maybe I'll implement something to make that easier in the next version, I haven't figured out what the best way is yet.
Reply
#46
Hi!
First of all, Leenm thanks for your work.

Now, there's this thing.
My ISP hosting forces me to use a special user for send newsletter. It's for figthing spam.
And when I press "Test send to administrator" the plug-in send the test to this e-mail address I can't read.

So I prefer to send the test to the global admin e-mail. Tha ddress set in "settings" section of GetSimple.
As maybe some one also likes it, I send the patch.
The new behavior is:
The test is sended to global admin e-mail instead of newsletter sender.

Regards
Luis
Reply
#47
I'll see what I can do in the next version, maybe make it optional for cases like this.
Reply
#48
Good idea.

Thanks as always.

Regards
Luis
Reply
#49
New version available:
  • Added filters for use in content
  • Added option to send admin email to site admin
  • Hide send to subscribers button when already send
Download: http://get-simple.info/extend/plugin/mld...etter/310/
Reply
#50
Hi,
thanks for your work leenm.
It works great.

Anyway I found a couple of issues.
1. If the newsletter archive (% mldnewsletterarchive %) it's not in the main page, the form doesn't work well, because of the URL on "action" (when you choose a newsletter it goes to index.php).
2. The newsletter archive always shows the first newsletter because of a typing error (an = instead of an ==).

I send a patch.

Regards
Luis
P.S. There's another way to send you patches?
Reply




Users browsing this thread: 1 Guest(s)
Free HDTV Channels Residential Solar Panels