Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Password email is not sent
Hi all,

I wanted to try out getsimple, but can't get past the install. The password email is not arriving in my inbox, nor in spam.

There are no warnings about missing modules or anything. I also have a contact page on my website at which sends emails using php, and these do arrive.

Any ideas would be appreciated!



I turned on debug mode. Here are the errors:

Strict Standards: main() [function.main]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /home/.../public_html/nbc/admin/inc/common.php on line 147

Notice: Undefined variable: SITEURL in /home/.../public_html/nbc/admin/inc/common.php on line 147

Notice: Undefined variable: SITENAME in /home/.../public_html/nbc/admin/inc/common.php on line 149

Notice: Undefined variable: kill in /home/.../public_html/nbc/admin/install.php on line 129
tdem Wrote:Hi all,

I wanted to try out getsimple, but can't get past the install. The password email is not arriving in my inbox, nor in spam.

If there is no mail server set up on your host (e.g. Windows hosts) or it does not forward the mails to your email address, you will not get the password email. But you are logged in immediately after installation, so just go to the settings tab and set a new password.
I18N, I18N Search, I18N Gallery, I18N Special Pages - essential plugins for multi-language sites.
Thanks for your reply mvlcek,

My host runs linux, and the mail function is available and working. More interesting though, it appears that after installing I should be logged in. This is certainly not the case!

In fact, I can't even log into the demo cms set up on opensource cms! This reminds me a lot of when I tried to install punbb a while back. There is a known issue to do with timezones, where a cookie is set in the past, so it is already expired (I think). In fact, to log into this forum here I have to tick the "stay logged in" box or else I'm not logged in.

Ok... I just tried setting up a second user following the instructions here:
Now I have a known password to log in. It didn't work.

Then I tried in firefox. Sucess!!! I was logged into the new account that I created. I then logged out and tried to use the password recovery for the admin user. But no recovery email was sent. So still no go on the admin account then.

So, in theory, I could now copy a known password hash into the admin.xml file. This would still leave me unable to use my preferred browser, and the password recovery is not working.

I suspect the error message that pops up on every page regarding timezones is somehow the culprit, but I don't know anything about php. Any ideas?
can you turn on GSDEBUG in the gsconfig.php file and see if there are any errors.
My Github Repos: Github
Website: DigiMute
How did you send all GS files to your hosting account ?
Did the situation occure with every GS installation you have tried ?

I think there's a problem with file saving (improper rights? hosting doesn't meet GS reqs?), as variables such as siteurl and sitename are being saved upon installation in config.xml
Addons: blue business theme, Online Visitors, Notepad
The debug output was added to my original post later. I've tried uploading both the whole folder using ftp, and uploading as a compressed file using a web based ftp client which decompresses it.

As far as I can see all the hosting requirements are met, and I checked permissions also.

I can't find any config.xml file though? Where should this be located?

Thanks for your replies,
Looks like there is a problem with website.xml file in /data/other/website.xml

Can you see if that file exists and there in information in it relevant to your site.
My Github Repos: Github
Website: DigiMute
It's there, The contents are as follows:

<?xml version="1.0"?>

Well, since the problem is only occurring in one browser, and I'll be setting this up on someone else's server later anyway, I've decided to just use firefox for now to work with the site.

Thanks for trying to help me. And congratulations on GetSimple. I've tried pretty much all the flat file and sqlite cms's the last few days, and GetSimple is hands down the best. It has all the features I need; it's easy to link to other pages within a site, or to files such as pdf's etc. Surprisingly, this is quite unusual!

On top of that there is an active forum, excellent documentation, excellent plugins and it's easy to theme.

Well done and thank you!
Try clearing your cookies ?
Also you usually have to setup your email in gsconfig before running install
NEW: SA Admin Toolbar Plugin | View All My Plugins
- Shawn A aka Tablatronix

Users browsing this thread: 1 Guest(s)